summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-12-20 09:47:13 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-12-20 09:47:13 +0000
commit784a176bc38c0dea540217dd5c7f6f0c77e89205 (patch)
tree3faa4c79f9f8324ed7e37a732026cc3a7d28a9dc /CMakeLists.txt
parentec33e8dcd668ce0f54bc9d6e5b5c9e3e13ac5c43 (diff)
downloadllvm-784a176bc38c0dea540217dd5c7f6f0c77e89205.tar.gz
llvm-784a176bc38c0dea540217dd5c7f6f0c77e89205.tar.bz2
llvm-784a176bc38c0dea540217dd5c7f6f0c77e89205.tar.xz
New cmake option LLVM_APPEND_VC_REV for controlling when the VC
revision id is appended to the LLVM version string. Defaults to OFF. Until now the VC revision id was always appended to the revision string whenever cmake was invoked (either explicitly or implicitly because a cmake source file changed). This was causing massive recompilations because config.h are reconfigured with the new contents of PACKAGE_VERSION. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@122240 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df2f8d5d51..3f48b58f43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,8 +11,15 @@ set(CMAKE_MODULE_PATH
)
set(PACKAGE_VERSION "2.9")
+
include(VersionFromVCS)
-add_version_info_from_vcs(PACKAGE_VERSION)
+
+option(LLVM_APPEND_VC_REV
+ "Append the version control system revision id to LLVM version" OFF)
+
+if( LLVM_APPEND_VC_REV )
+ add_version_info_from_vcs(PACKAGE_VERSION)
+endif()
set(PACKAGE_NAME llvm)
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")