summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-06-23 17:57:35 +0000
committerDouglas Gregor <dgregor@apple.com>2009-06-23 17:57:35 +0000
commit7e9e36a23e07dfb0d7ceda3e76450073c0534f35 (patch)
treeab89cfc44d7d6580e19a2d33465f6e167b75a382 /CMakeLists.txt
parent83a2129332250af4648e0501f93cabfa8873e1f4 (diff)
downloadllvm-7e9e36a23e07dfb0d7ceda3e76450073c0534f35.tar.gz
llvm-7e9e36a23e07dfb0d7ceda3e76450073c0534f35.tar.bz2
llvm-7e9e36a23e07dfb0d7ceda3e76450073c0534f35.tar.xz
Eliminate object-relinking support from CMake. Fixes PR 4429 and
cleans up the CMake-based build system a bit. Started by a patch from Xerxes RĂ„nby. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@73969 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 543ee7f880..2ee79a568d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,9 +180,6 @@ set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
add_llvm_definitions( -D__STDC_LIMIT_MACROS )
add_llvm_definitions( -D__STDC_CONSTANT_MACROS )
-set(LLVM_PLO_FLAGS "" CACHE
- STRING "Flags for creating partially linked objects.")
-
if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
# TODO: support other platforms and toolchains.
option(LLVM_BUILD_32_BITS "Build 32 bits executables and libraries." OFF)
@@ -221,7 +218,6 @@ endif( MSVC )
include_directories( ${LLVM_BINARY_DIR}/include ${LLVM_MAIN_INCLUDE_DIR})
include(AddLLVM)
-include(AddPartiallyLinkedObject)
include(TableGen)
add_subdirectory(lib/Support)