summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Northover <Tim.Northover@arm.com>2013-04-10 12:08:57 +0000
committerTim Northover <Tim.Northover@arm.com>2013-04-10 12:08:57 +0000
commit7ef742dca17ee5971af94cda040f545cdd3464b2 (patch)
tree3127a813f8bd091274591446e17d831f30970cdf /CMakeLists.txt
parent8c9e52a9fc1f99cf80c499ef10e6c8a54ef899d4 (diff)
downloadllvm-7ef742dca17ee5971af94cda040f545cdd3464b2.tar.gz
llvm-7ef742dca17ee5971af94cda040f545cdd3464b2.tar.bz2
llvm-7ef742dca17ee5971af94cda040f545cdd3464b2.tar.xz
Revert "TMP"
This reverts commit e652085eacbec62e4157d08d3f2f875e6e6d5bb4. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@179172 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8c3038eba..1d216924b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,8 +91,13 @@ set(LLVM_ALL_TARGETS
# List of targets with JIT support:
set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM Mips)
-set(LLVM_TARGETS_TO_BUILD "all"
+if( MSVC )
+ set(LLVM_TARGETS_TO_BUILD X86
+ CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
+else( MSVC )
+ set(LLVM_TARGETS_TO_BUILD "all"
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
+endif( MSVC )
set(LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ""
CACHE STRING "Semicolon-separated list of experimental targets to build.")