summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-11-15 22:51:03 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-11-15 22:51:03 +0000
commit7f6f21ebaec41354c20b241483adc45def794db4 (patch)
tree8caef63fe329039f17f36cab9193f37fb47e52df /CMakeLists.txt
parent92adc19be95347225f713db8cc1b5e22ac08bb5e (diff)
downloadllvm-7f6f21ebaec41354c20b241483adc45def794db4.tar.gz
llvm-7f6f21ebaec41354c20b241483adc45def794db4.tar.bz2
llvm-7f6f21ebaec41354c20b241483adc45def794db4.tar.xz
CMake: Forces linking of the rest of architecture targets and its
respective asm printers on MSVC. Based on a patch by Scott Graham. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@59379 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05c5895796..6ef79b91de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,10 @@ set(LLVM_ALL_TARGETS
XCore
)
+# List of targets whose asmprinters need to be forced to link
+# into executables on some platforms (i.e. Windows):
+set(LLVM_ASMPRINTERS_FORCE_LINK X86 PowerPC)
+
if( MSVC )
set(LLVM_TARGETS_TO_BUILD X86
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")