summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2010-07-20 18:25:19 +0000
committerChris Lattner <sabre@nondot.org>2010-07-20 18:25:19 +0000
commit847da55716e9c1d39c08ed052bc86d28796cb91f (patch)
treee7cc007870c19d31799084136675b1c2a79417ec /CMakeLists.txt
parentc4fd9afaf959309f9e522aae8facf936aaaf9ee4 (diff)
downloadllvm-847da55716e9c1d39c08ed052bc86d28796cb91f.tar.gz
llvm-847da55716e9c1d39c08ed052bc86d28796cb91f.tar.bz2
llvm-847da55716e9c1d39c08ed052bc86d28796cb91f.tar.xz
start straightening out libedis's dependencies and make it fit
better in the llvm world. Among other things, this changes: 1. The guts of libedis are now moved into lib/MC/MCDisassembler 2. llvm-mc now depends on lib/MC/MCDisassembler, not tools/edis, so edis and mc don't have to be built in series. 3. lib/MC/MCDisassembler no longer depends on the C api, the C API depends on it. 4. Various code cleanup changes. There is still a lot to be done to make edis fit with the llvm design, but this is an incremental step in the right direction. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@108869 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4f2221c9f..a4babed29f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -308,6 +308,7 @@ add_subdirectory(lib/Analysis)
add_subdirectory(lib/Analysis/IPA)
add_subdirectory(lib/MC)
add_subdirectory(lib/MC/MCParser)
+add_subdirectory(lib/MC/MCDisassembler)
add_subdirectory(test)
add_subdirectory(utils/FileCheck)