summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-06-23 18:30:17 +0000
committerDouglas Gregor <dgregor@apple.com>2009-06-23 18:30:17 +0000
commit8756a8db5b14fac4ad7e3a0a11cc0b3c115e826d (patch)
tree49a9a83bd9019b2c022b02a1223f0a615cf1f7ee /CMakeLists.txt
parent14112e51697e56788fcb32f4255833499c2738b5 (diff)
downloadllvm-8756a8db5b14fac4ad7e3a0a11cc0b3c115e826d.tar.gz
llvm-8756a8db5b14fac4ad7e3a0a11cc0b3c115e826d.tar.bz2
llvm-8756a8db5b14fac4ad7e3a0a11cc0b3c115e826d.tar.xz
CMake: remove support for llvm-config-generated dependencies in the build
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@73979 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ee79a568d..d94506ff46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,24 +100,6 @@ configure_file(
set(llvm_builded_incs_dir ${LLVM_BINARY_DIR}/include/llvm)
-# The USE_EXPLICIT_DEPENDENCIES variable will be TRUE to indicate that
-# we should use the library dependencies explicitly specified in the
-# CMakeLists.txt files rather than those determined by
-# llvm-config. This value must be true for non-make and IDE
-# generators.
-if (MSVC_IDE)
- set(DEFAULT_USE_EXPLICIT_DEPENDENCIES ON)
-elseif (XCODE)
- set(DEFAULT_USE_EXPLICIT_DEPENDENCIES ON)
-else ()
- set(DEFAULT_USE_EXPLICIT_DEPENDENCIES OFF)
-endif ()
-
-option(USE_EXPLICIT_DEPENDENCIES
- "Use explicit dependencies instead of llvm-config"
- ${DEFAULT_USE_EXPLICIT_DEPENDENCIES})
-mark_as_advanced(USE_EXPLICIT_DEPENDENCIES)
-
# Add path for custom modules
set(CMAKE_MODULE_PATH
${CMAKE_MODULE_PATH}