summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-11-21 22:47:21 +0000
committerHans Wennborg <hans@hanshq.net>2013-11-21 22:47:21 +0000
commit896a0a27f7dd7113555afc5ab7afccb3894f2ba3 (patch)
treee1be23283d355e25a9d1239ce9f8fa1aabd072bc /CMakeLists.txt
parent1aeae92c07fe8993f24d55f8e7e2097aef9163ae (diff)
downloadllvm-896a0a27f7dd7113555afc5ab7afccb3894f2ba3.tar.gz
llvm-896a0a27f7dd7113555afc5ab7afccb3894f2ba3.tar.bz2
llvm-896a0a27f7dd7113555afc5ab7afccb3894f2ba3.tar.xz
CMake: Some changes to package version names:
- Allow overriding PACKAGE_VERSION from the command-line - Use PACKAGE_VERSION to set CPACK_PACKAGE_VERSION (used by the Win installer) - Don't include the version number in the CPack install dir or registry key. Differential revision: http://llvm-reviews.chandlerc.com/D2245 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@195379 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f43204f170..551b17828b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,9 @@ set(CMAKE_MODULE_PATH
set(LLVM_VERSION_MAJOR 3)
set(LLVM_VERSION_MINOR 5)
-set(PACKAGE_VERSION "${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}svn")
+if (NOT PACKAGE_VERSION)
+ set(PACKAGE_VERSION "${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}svn")
+endif()
option(LLVM_INSTALL_TOOLCHAIN_ONLY "Only include toolchain files in the 'install' target." OFF)
@@ -36,16 +38,14 @@ set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_BUGREPORT "http://llvm.org/bugs/")
# Configure CPack.
+set(CPACK_PACKAGE_INSTALL_DIRECTORY "LLVM")
set(CPACK_PACKAGE_VENDOR "LLVM")
set(CPACK_PACKAGE_VERSION_MAJOR ${LLVM_VERSION_MAJOR})
set(CPACK_PACKAGE_VERSION_MINOR ${LLVM_VERSION_MINOR})
-if( LLVM_APPEND_VC_REV )
- add_version_info_from_vcs(CPACK_PACKAGE_VERSION_PATCH)
-else()
- set(CPACK_PACKAGE_VERSION_PATCH "svn")
-endif()
+set(CPACK_PACKAGE_VERSION ${PACKAGE_VERSION})
set(CPACK_RESOURCE_FILE_LICENSE "${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.TXT")
if(WIN32 AND NOT UNIX)
+ set(CPACK_PACKAGE_INSTALL_REGISTRY_KEY "LLVM")
set(CPACK_PACKAGE_ICON "${CMAKE_CURRENT_SOURCE_DIR}\\\\cmake\\\\nsis_logo.bmp")
set(CPACK_NSIS_MODIFY_PATH "ON")
set(CPACK_NSIS_ENABLE_UNINSTALL_BEFORE_INSTALL "ON")