summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Pichet <pichet2000@gmail.com>2010-12-07 01:25:06 +0000
committerFrancois Pichet <pichet2000@gmail.com>2010-12-07 01:25:06 +0000
commit97b2f727650357c5e3634853463e2fe493f4cdf7 (patch)
tree3ab691d611a5670e0adc0c06b1ce44617f3aee4f /CMakeLists.txt
parent44d392a6afd467784b7d71ab42c8c128102d2e2c (diff)
downloadllvm-97b2f727650357c5e3634853463e2fe493f4cdf7.tar.gz
llvm-97b2f727650357c5e3634853463e2fe493f4cdf7.tar.bz2
llvm-97b2f727650357c5e3634853463e2fe493f4cdf7.tar.xz
Promote "enumerator in switch of enum is not handled" to level 1 warning on MSVC. It was disabled by default.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@121096 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 371d73bbd9..2d1f66bfc1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,7 +247,10 @@ if( MSVC )
add_llvm_definitions( -D_SCL_SECURE_NO_DEPRECATE )
add_llvm_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 -wd4267 -wd4291 )
- add_llvm_definitions( -wd4275)
+ add_llvm_definitions( -wd4275 )
+
+ # Promote "enumerator in switch of enum is not handled" to level 1 warning.
+ add_llvm_definitions( -w14062 )
# Suppress 'new behavior: elements of array 'array' will be default initialized'
add_llvm_definitions( -wd4351 )