summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2009-12-01 19:11:36 +0000
committerDaniel Dunbar <daniel@zuster.org>2009-12-01 19:11:36 +0000
commit9ea3a2c9fc64bd7ac459ffea050c81c0c793f7ca (patch)
tree55526585ce450a9c9139bade9734214e46d1758e /CMakeLists.txt
parentc09ddc1c792b35a20b2aeaa708fd00a76638805c (diff)
downloadllvm-9ea3a2c9fc64bd7ac459ffea050c81c0c793f7ca.tar.gz
llvm-9ea3a2c9fc64bd7ac459ffea050c81c0c793f7ca.tar.bz2
llvm-9ea3a2c9fc64bd7ac459ffea050c81c0c793f7ca.tar.xz
Don't default warnings to ON on MSVC, the spew is enough to triple the build time. :/
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@90251 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ad466901a..9bce0392db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,7 +191,13 @@ set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
add_llvm_definitions( -D__STDC_LIMIT_MACROS )
add_llvm_definitions( -D__STDC_CONSTANT_MACROS )
-option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." ON)
+# MSVC has a gazillion warnings with this.
+if( MSVC )
+ option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." OFF)
+else( MSVC )
+ option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." ON)
+endif()
+
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)