summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-09-24 19:27:54 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-09-24 19:27:54 +0000
commita789af239ca97bf23a268101f9f6e89d3f164647 (patch)
tree15f842b8a40d1b1fee836bca0e6f758da0b0a529 /CMakeLists.txt
parent7c3a913944d852f50f8a8e7b505947960c525acc (diff)
downloadllvm-a789af239ca97bf23a268101f9f6e89d3f164647.tar.gz
llvm-a789af239ca97bf23a268101f9f6e89d3f164647.tar.bz2
llvm-a789af239ca97bf23a268101f9f6e89d3f164647.tar.xz
CMake: Disabled some warnings for MSVC.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@56565 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31f754a953..039b139565 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,8 @@ if( MSVC )
add_definitions( -D_CRT_SECURE_NO_DEPRECATE -D_CRT_SECURE_NO_WARNINGS )
add_definitions( -D_SCL_SECURE_NO_WARNINGS -DCRT_NONSTDC_NO_WARNINGS )
add_definitions( -D_SCL_SECURE_NO_DEPRECATE )
+ add_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
+ add_definitions( -wd4355 -wd4715 )
endif( MSVC )
include_directories( ${LLVM_BINARY_DIR}/include ${llvm_include_path})