summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2012-08-02 19:16:56 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2012-08-02 19:16:56 +0000
commita915f247f72570a994d55cd0d2961cd2d7bbd0e1 (patch)
tree51bbc92eb6c125a893d516d180a15c4fb71752ba /CMakeLists.txt
parentcfbda4a04dacaf976505c54a5308f6954b3b9a58 (diff)
downloadllvm-a915f247f72570a994d55cd0d2961cd2d7bbd0e1.tar.gz
llvm-a915f247f72570a994d55cd0d2961cd2d7bbd0e1.tar.bz2
llvm-a915f247f72570a994d55cd0d2961cd2d7bbd0e1.tar.xz
Add yaml2obj. A utility to convert YAML to binaries.
yaml2obj takes a textual description of an object file in YAML format and outputs the binary equivalent. This greatly simplifies writing tests that take binary object files as input. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161205 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb64db91bc..ed230aee5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -402,6 +402,7 @@ add_subdirectory(utils/not)
add_subdirectory(utils/llvm-lit)
add_subdirectory(utils/yaml-bench)
add_subdirectory(utils/obj2yaml)
+add_subdirectory(utils/yaml2obj)
add_subdirectory(projects)