summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-09-13 22:18:38 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-09-13 22:18:38 +0000
commita9ff1392ea5d21b2dd9fbe37a0f268b2834211d0 (patch)
tree92c96d1e53d8fe9556bd93072415ac604e6354ea /CMakeLists.txt
parent422094c38dfe6878de40f4ad443dcd77542fac22 (diff)
downloadllvm-a9ff1392ea5d21b2dd9fbe37a0f268b2834211d0.tar.gz
llvm-a9ff1392ea5d21b2dd9fbe37a0f268b2834211d0.tar.bz2
llvm-a9ff1392ea5d21b2dd9fbe37a0f268b2834211d0.tar.xz
CMake: New user-settable variable LLVM_TARGET_ARCH useful when
cross-compiling. Patch by Xerxes RĂ„nby! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@81722 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6036f02bd..4e48ef6b59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,9 @@ else( MSVC )
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )
+set(LLVM_TARGET_ARCH "host"
+ CACHE STRING "Set target to use for LLVM JIT or use \"host\" for automatic detection.")
+
option(LLVM_ENABLE_THREADS "Use threads if available." ON)
if( uppercase_CMAKE_BUILD_TYPE STREQUAL "RELEASE" )