summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2011-11-04 19:04:23 +0000
committerDaniel Dunbar <daniel@zuster.org>2011-11-04 19:04:23 +0000
commitb0d9ce567f5aee3af94c290d7cd52b1582c27b4f (patch)
treecf2b86b94d23ce5d4469ea5b40b31358fa98b707 /CMakeLists.txt
parentb0527283682c5f44fae24ae0a7e2e794f019fade (diff)
downloadllvm-b0d9ce567f5aee3af94c290d7cd52b1582c27b4f.tar.gz
llvm-b0d9ce567f5aee3af94c290d7cd52b1582c27b4f.tar.bz2
llvm-b0d9ce567f5aee3af94c290d7cd52b1582c27b4f.tar.xz
build/cmake: Use tblgen macro directly instead of llvm_tablegen, which just
added a layer of indirection with no value (not even conciseness). git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@143727 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 139169db3d..63682487b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -184,10 +184,6 @@ endif( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
include(AddLLVM)
include(TableGen)
-macro(llvm_tablegen)
- tablegen(LLVM ${ARGN})
-endmacro()
-
if( MINGW )
# People report that -O3 is unreliable on MinGW. The traditional
# build also uses -O2 for that reason: