summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2014-03-01 03:16:07 +0000
committerChandler Carruth <chandlerc@gmail.com>2014-03-01 03:16:07 +0000
commitb23750a8ae1628d98d6b0ad0ec3e975a3c42863b (patch)
tree8d427bb522989c8818c2d5e790d9dfe9834dfc2c /CMakeLists.txt
parentf468dea807ee7350ba9814ebda0047e97738aba0 (diff)
downloadllvm-b23750a8ae1628d98d6b0ad0ec3e975a3c42863b.tar.gz
llvm-b23750a8ae1628d98d6b0ad0ec3e975a3c42863b.tar.bz2
llvm-b23750a8ae1628d98d6b0ad0ec3e975a3c42863b.tar.xz
[C++11] Switch the CMake option from LLVM_ENABLE_CXX11 (default on) to
LLVM_ENABLE_CXX1Y (default *off*). =D C++98 is dead. Long live C++11. I don't exactly recommend using C++1y just yet though... git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202567 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb781ce799..835cb58fcc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -198,7 +198,7 @@ else( MSVC )
option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." ON)
endif()
-option(LLVM_ENABLE_CXX11 "Compile with C++11 enabled." ON)
+option(LLVM_ENABLE_CXX1Y "Compile with C++1y enabled." OFF)
option(LLVM_ENABLE_LIBCXX "Use libc++ if available." OFF)
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)