summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Pichet <pichet2000@gmail.com>2010-10-12 00:01:36 +0000
committerFrancois Pichet <pichet2000@gmail.com>2010-10-12 00:01:36 +0000
commitb2b9b768ef59d7b18a8b6f06cce5a8c80aa11f9e (patch)
tree5a9e63239f72f95a167d198869778fb7e87db80b /CMakeLists.txt
parentc0157231313c96cdeebc16a4fe94d9b9d3f2a45e (diff)
downloadllvm-b2b9b768ef59d7b18a8b6f06cce5a8c80aa11f9e.tar.gz
llvm-b2b9b768ef59d7b18a8b6f06cce5a8c80aa11f9e.tar.bz2
llvm-b2b9b768ef59d7b18a8b6f06cce5a8c80aa11f9e.tar.xz
Disable warning C4267 for MSVC. Otherwise it generate literally thousands of warnings when targeting x64. The warning occurs because int is 32 bit but size_t is 64 bit on Win64.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116274 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c3f0b1b11f..170b590825 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -222,7 +222,7 @@ if( MSVC )
add_llvm_definitions( -D_SCL_SECURE_NO_WARNINGS -DCRT_NONSTDC_NO_WARNINGS )
add_llvm_definitions( -D_SCL_SECURE_NO_DEPRECATE )
add_llvm_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
- add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 )
+ add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 -wd4267 )
# Suppress 'new behavior: elements of array 'array' will be default initialized'
add_llvm_definitions( -wd4351 )