summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Pichet <pichet2000@gmail.com>2010-12-04 14:30:22 +0000
committerFrancois Pichet <pichet2000@gmail.com>2010-12-04 14:30:22 +0000
commitb361452ef9ad9453b2874cd12fc9ee65085d1f57 (patch)
tree7e38617bbb3dcd021b43b5664c8f34b650460699 /CMakeLists.txt
parent983839609ffa589cda60efaea847eecede77b524 (diff)
downloadllvm-b361452ef9ad9453b2874cd12fc9ee65085d1f57.tar.gz
llvm-b361452ef9ad9453b2874cd12fc9ee65085d1f57.tar.bz2
llvm-b361452ef9ad9453b2874cd12fc9ee65085d1f57.tar.xz
Disable C++ exception handling on MSVC.
Total size of bin\Release on disk goes from 82.9 MB to 74.2 MB. (~10% saving) git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@120908 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28e90475d4..371d73bbd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,6 +247,7 @@ if( MSVC )
add_llvm_definitions( -D_SCL_SECURE_NO_DEPRECATE )
add_llvm_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 -wd4267 -wd4291 )
+ add_llvm_definitions( -wd4275)
# Suppress 'new behavior: elements of array 'array' will be default initialized'
add_llvm_definitions( -wd4351 )