summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-11-23 00:21:43 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-11-23 00:21:43 +0000
commitb8352de5514276e7e66998744e5d9eb477076d29 (patch)
tree8e48b43830ed8b555d67e2445ea5996acd13871d /CMakeLists.txt
parentead2dacc9ee028906cb104c8c3d66ccbbebe6b10 (diff)
downloadllvm-b8352de5514276e7e66998744e5d9eb477076d29.tar.gz
llvm-b8352de5514276e7e66998744e5d9eb477076d29.tar.bz2
llvm-b8352de5514276e7e66998744e5d9eb477076d29.tar.xz
CMake: generate targets for tools and examples even when
LLVM_BUILD_TOOLS or LLVM_BUILD_EXAMPLES are OFF. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@89635 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00214782ca..a7a595a8eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -319,14 +319,10 @@ add_subdirectory(lib/Archive)
add_subdirectory(projects)
option(LLVM_BUILD_TOOLS "Build LLVM tool programs." ON)
-if(LLVM_BUILD_TOOLS)
- add_subdirectory(tools)
-endif()
+add_subdirectory(tools)
option(LLVM_BUILD_EXAMPLES "Build LLVM example programs." OFF)
-if(LLVM_BUILD_EXAMPLES)
- add_subdirectory(examples)
-endif ()
+add_subdirectory(examples)
install(DIRECTORY include/
DESTINATION include