summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-10-02 02:38:42 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-10-02 02:38:42 +0000
commitbab2b012d65127ca4d6fafb47ae5dbe12320201e (patch)
tree66f5e934cf00875834fccebbaafec35e9c3af245 /CMakeLists.txt
parentf70007e89e7b252abc9dc175aab92191c09bebf7 (diff)
downloadllvm-bab2b012d65127ca4d6fafb47ae5dbe12320201e.tar.gz
llvm-bab2b012d65127ca4d6fafb47ae5dbe12320201e.tar.bz2
llvm-bab2b012d65127ca4d6fafb47ae5dbe12320201e.tar.xz
Handle InstPrinter's on the CMake build.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@115402 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ad68a0457..d473f51b59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -324,6 +324,11 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
set(LLVM_ENUM_ASM_PRINTERS
"${LLVM_ENUM_ASM_PRINTERS}LLVM_ASM_PRINTER(${t})\n")
endif( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmPrinter/CMakeLists.txt )
+ if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/InstPrinter/CMakeLists.txt )
+ add_subdirectory(lib/Target/${t}/InstPrinter)
+ set(LLVM_ENUM_ASM_PRINTERS
+ "${LLVM_ENUM_ASM_PRINTERS}LLVM_ASM_PRINTER(${t})\n")
+ endif( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/InstPrinter/CMakeLists.txt )
if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmParser/CMakeLists.txt )
add_subdirectory(lib/Target/${t}/AsmParser)
set(LLVM_ENUM_ASM_PARSERS