summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Noblesmith <nobled@dreamwidth.org>2012-02-01 14:49:39 +0000
committerDylan Noblesmith <nobled@dreamwidth.org>2012-02-01 14:49:39 +0000
commitbb7cd0cf31f845b9445b5fa35d0b52dd096609ad (patch)
tree921d28539a9ae38a619202b34e48debd427cebce /CMakeLists.txt
parent3a14d0f0fd50a16ad65e961713c20335e43a319a (diff)
downloadllvm-bb7cd0cf31f845b9445b5fa35d0b52dd096609ad.tar.gz
llvm-bb7cd0cf31f845b9445b5fa35d0b52dd096609ad.tar.bz2
llvm-bb7cd0cf31f845b9445b5fa35d0b52dd096609ad.tar.xz
cmake: make BUILD_SHARED_LIBS a visible option
It could only be specified on the commandline, and wouldn't show up as an option in the GUI or when invoked via `cmake -i` at all. This also tells CMake that it's a BOOL, rather than "UNINITIALIZED". git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@149506 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13e358a461..1e7a4a340f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,9 @@ else( MSVC )
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )
+option(BUILD_SHARED_LIBS
+ "Build all libraries as shared libraries instead of static" OFF)
+
option(LLVM_ENABLE_CBE_PRINTF_A "Set to ON if CBE is enabled for printf %a output" ON)
if(LLVM_ENABLE_CBE_PRINTF_A)
set(ENABLE_CBE_PRINTF_A 1)