summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Lewycky <nicholas@mxc.ca>2011-04-29 02:12:06 +0000
committerNick Lewycky <nicholas@mxc.ca>2011-04-29 02:12:06 +0000
commitbcffb1fbb85a88cb99f7c2115a5f78e860d7fc46 (patch)
treea7e400febef581e1c8ce058f0cc40e33c6a39993 /CMakeLists.txt
parent6344a5f1464dade7735ac440d7a3d24bf009f298 (diff)
downloadllvm-bcffb1fbb85a88cb99f7c2115a5f78e860d7fc46.tar.gz
llvm-bcffb1fbb85a88cb99f7c2115a5f78e860d7fc46.tar.bz2
llvm-bcffb1fbb85a88cb99f7c2115a5f78e860d7fc46.tar.xz
Rename profile_rt.so to libprofile_rt.so under configure+make (it already was
under cmake). Add libprofile_rt.a so that we can tell clang to link against it in --coverage mode. Also turn it on by default in cmake builds. Oscar, this touches a change you made for EXCLUDE_FROM_ALL support -- I think I've done the right thing, but please let me know (or fix and commit) if not! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@130470 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38a9f2b227..e0404cf4b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,7 +228,7 @@ if( LLVM_INCLUDE_TOOLS )
endif()
option(LLVM_BUILD_RUNTIME
- "Build the LLVM runtime libraries. If OFF, just generate build targets." OFF)
+ "Build the LLVM runtime libraries. If OFF, just generate build targets." ON)
option(LLVM_INCLUDE_RUNTIME "Generate build targets for the LLVM runtimes" ON)
if( LLVM_INCLUDE_RUNTIME )
add_subdirectory(runtime)