summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-14 20:13:58 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-14 20:13:58 +0000
commitc08830d46d7a5943fdb5e0d21354d9c06aa21b0e (patch)
tree92b5446f5c04bcc5d8d5b26c79304751dcd05a96 /CMakeLists.txt
parent75831904220042260c4faece8507a2807acba47f (diff)
downloadllvm-c08830d46d7a5943fdb5e0d21354d9c06aa21b0e.tar.gz
llvm-c08830d46d7a5943fdb5e0d21354d9c06aa21b0e.tar.bz2
llvm-c08830d46d7a5943fdb5e0d21354d9c06aa21b0e.tar.xz
Add current binary and source directories to the header search list
for all compiler invocations. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@125513 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41f4141140..ce559ed783 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -169,6 +169,8 @@ endif()
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
include_directories( ${LLVM_BINARY_DIR}/include ${LLVM_MAIN_INCLUDE_DIR})
if( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )