summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward O'Callaghan <eocallaghan@auroraux.org>2009-10-12 04:00:11 +0000
committerEdward O'Callaghan <eocallaghan@auroraux.org>2009-10-12 04:00:11 +0000
commitc6cf5fe595cd3cec3f8320ec29118e0e2b39b28c (patch)
tree95e967ebd4f9afcde503347311dbebdbadc6a5ad /CMakeLists.txt
parent67f7d549db4c6e578454c740ba0c3931304bef3b (diff)
downloadllvm-c6cf5fe595cd3cec3f8320ec29118e0e2b39b28c.tar.gz
llvm-c6cf5fe595cd3cec3f8320ec29118e0e2b39b28c.tar.bz2
llvm-c6cf5fe595cd3cec3f8320ec29118e0e2b39b28c.tar.xz
Fix LLVM CMake build system so that it may now work on Solaris and AuroraUX.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@83819 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b22a8c239d..f7126584ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,6 +221,10 @@ endif( MSVC )
include_directories( ${LLVM_BINARY_DIR}/include ${LLVM_MAIN_INCLUDE_DIR})
+if( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
+ SET(CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS} "-include llvm/System/Solaris.h")
+endif( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
+
include(AddLLVM)
include(TableGen)