summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-08-16 20:56:30 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-08-16 20:56:30 +0000
commitc81f56d9ec9e58d68187579af40d0ef645843766 (patch)
treecd38360211cd7f7601a5ba9fa46990c1584515ea /CMakeLists.txt
parentc23a8d133c7a1a1b5467239334c664352d10d81f (diff)
downloadllvm-c81f56d9ec9e58d68187579af40d0ef645843766.tar.gz
llvm-c81f56d9ec9e58d68187579af40d0ef645843766.tar.bz2
llvm-c81f56d9ec9e58d68187579af40d0ef645843766.tar.xz
CMake: New option LLVM_BUILD_TOOLS. Renamed LLVM_EXAMPLES to
LLVM_BUILD_EXAMPLES and set default to true. Documented. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@79203 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8e86d0d3c..3067118108 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -302,10 +302,14 @@ add_subdirectory(lib/Debugger)
add_subdirectory(lib/Archive)
add_subdirectory(projects)
-add_subdirectory(tools)
-option(LLVM_EXAMPLES "Build LLVM example programs." OFF)
-if (LLVM_EXAMPLES)
+option(LLVM_BUILD_TOOLS "Build LLVM tool programs." ON)
+if(LLVM_BUILD_TOOLS)
+ add_subdirectory(tools)
+endif()
+
+option(LLVM_BUILD_EXAMPLES "Build LLVM example programs." ON)
+if(LLVM_BUILD_EXAMPLES)
add_subdirectory(examples)
endif ()