summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2012-06-30 10:14:14 +0000
committerChandler Carruth <chandlerc@gmail.com>2012-06-30 10:14:14 +0000
commitcf23bd3d8f7e7dec6331043295dbf1ec92fedb4f (patch)
treef61604d3008869df25f055573b397557e15912e1 /CMakeLists.txt
parentac24e251014de60a16558fc0a1f2340c334d2aa8 (diff)
downloadllvm-cf23bd3d8f7e7dec6331043295dbf1ec92fedb4f.tar.gz
llvm-cf23bd3d8f7e7dec6331043295dbf1ec92fedb4f.tar.bz2
llvm-cf23bd3d8f7e7dec6331043295dbf1ec92fedb4f.tar.xz
Hoist LLVM's lit testsuite infrastructure into module so that it can be
re-used. Also, build in direct support for accumulating a set of lit parameters, arguments, and testsuites to run as part of a 'check-all' rule. This sinks 'check-all' from a Clang-specific construct to a generic construct of the project. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@159482 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 014b85fd1a..bb64db91bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -426,6 +426,20 @@ if( LLVM_INCLUDE_TESTS )
# Windows.
add_subdirectory(utils/KillTheDoctor)
endif()
+
+ # Add a global check rule now that all subdirectories have been traversed
+ # and we know the total set of lit testsuites.
+ get_property(LLVM_LIT_TESTSUITES GLOBAL PROPERTY LLVM_LIT_TESTSUITES)
+ get_property(LLVM_LIT_PARAMS GLOBAL PROPERTY LLVM_LIT_PARAMS)
+ get_property(LLVM_LIT_DEPENDS GLOBAL PROPERTY LLVM_LIT_DEPENDS)
+ get_property(LLVM_LIT_EXTRA_ARGS GLOBAL PROPERTY LLVM_LIT_EXTRA_ARGS)
+ add_lit_target(check-all
+ "Running all regression tests"
+ ${LLVM_LIT_TESTSUITES}
+ PARAMS ${LLVM_LIT_PARAMS}
+ DEPENDS ${LLVM_LIT_DEPENDS}
+ ARGS ${LLVM_LIT_EXTRA_ARGS}
+ )
endif()
add_subdirectory(cmake/modules)