summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-03 20:57:36 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-03 20:57:36 +0000
commitd538e249224a91f85bd4297c71b2bfa71113a9ad (patch)
treea0814fc6e53d64a7d02a4e61e77be8620b2c91f2 /CMakeLists.txt
parent2dfbb3e9125aa0a66feab7a7638815b57da85968 (diff)
downloadllvm-d538e249224a91f85bd4297c71b2bfa71113a9ad.tar.gz
llvm-d538e249224a91f85bd4297c71b2bfa71113a9ad.tar.bz2
llvm-d538e249224a91f85bd4297c71b2bfa71113a9ad.tar.xz
Changes for building Clang and others using LLVM as an external
library. Installs tblgen (required by Clang). Translates handling of user settings and platform-dependant options to its own file, where it can included by another project. Installs the .cmake files required by projects like Clang. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@124816 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt159
1 files changed, 19 insertions, 140 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9878c7991d..aaf6e9cb9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,28 +133,6 @@ set(LLVM_LIT_ARGS "${LIT_ARGS_DEFAULT}"
option(LLVM_ENABLE_THREADS "Use threads if available." ON)
-if( uppercase_CMAKE_BUILD_TYPE STREQUAL "RELEASE" )
- option(LLVM_ENABLE_ASSERTIONS "Enable assertions" OFF)
-else()
- option(LLVM_ENABLE_ASSERTIONS "Enable assertions" ON)
-endif()
-
-if( LLVM_ENABLE_ASSERTIONS )
- # MSVC doesn't like _DEBUG on release builds. See PR 4379.
- if( NOT MSVC )
- add_definitions( -D_DEBUG )
- endif()
- # On Release builds cmake automatically defines NDEBUG, so we
- # explicitly undefine it:
- if( uppercase_CMAKE_BUILD_TYPE STREQUAL "RELEASE" )
- add_definitions( -UNDEBUG )
- endif()
-else()
- if( NOT uppercase_CMAKE_BUILD_TYPE STREQUAL "RELEASE" )
- add_definitions( -DNDEBUG )
- endif()
-endif()
-
if( LLVM_TARGETS_TO_BUILD STREQUAL "all" )
set( LLVM_TARGETS_TO_BUILD ${LLVM_ALL_TARGETS} )
endif()
@@ -180,68 +158,34 @@ set(llvm_builded_incs_dir ${LLVM_BINARY_DIR}/include/llvm)
include(AddLLVMDefinitions)
-if(WIN32)
- if(CYGWIN)
- set(LLVM_ON_WIN32 0)
- set(LLVM_ON_UNIX 1)
- else(CYGWIN)
- set(LLVM_ON_WIN32 1)
- set(LLVM_ON_UNIX 0)
- endif(CYGWIN)
- set(LTDL_SHLIB_EXT ".dll")
- set(EXEEXT ".exe")
- # Maximum path length is 160 for non-unicode paths
- set(MAXPATHLEN 160)
-else(WIN32)
- if(UNIX)
- set(LLVM_ON_WIN32 0)
- set(LLVM_ON_UNIX 1)
- if(APPLE)
- set(LTDL_SHLIB_EXT ".dylib")
- else(APPLE)
- set(LTDL_SHLIB_EXT ".so")
- endif(APPLE)
- set(EXEEXT "")
- # FIXME: Maximum path length is currently set to 'safe' fixed value
- set(MAXPATHLEN 2024)
- else(UNIX)
- MESSAGE(SEND_ERROR "Unable to determine platform")
- endif(UNIX)
-endif(WIN32)
-
option(LLVM_ENABLE_PIC "Build Position-Independent Code" ON)
-if( LLVM_ENABLE_PIC )
- if( XCODE )
- # Xcode has -mdynamic-no-pic on by default, which overrides -fPIC. I don't
- # know how to disable this, so just force ENABLE_PIC off for now.
- message(WARNING "-fPIC not supported with Xcode.")
- elseif( WIN32 )
- # On Windows all code is PIC. MinGW warns if -fPIC is used.
- else()
- include(CheckCXXCompilerFlag)
- check_cxx_compiler_flag("-fPIC" SUPPORTS_FPIC_FLAG)
- if( SUPPORTS_FPIC_FLAG )
- message(STATUS "Building with -fPIC")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
- set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
- else( SUPPORTS_FPIC_FLAG )
- message(WARNING "-fPIC not supported.")
- endif()
- endif()
+include(config-ix)
+
+include(HandleLLVMOptions)
+
+if( uppercase_CMAKE_BUILD_TYPE STREQUAL "RELEASE" )
+ option(LLVM_ENABLE_ASSERTIONS "Enable assertions" OFF)
+else()
+ option(LLVM_ENABLE_ASSERTIONS "Enable assertions" ON)
endif()
-include(config-ix)
+configure_file(
+ ${LLVM_MAIN_INCLUDE_DIR}/llvm/Config/config.h.cmake
+ ${LLVM_BINARY_DIR}/include/llvm/Config/config.h)
+
+configure_file(
+ ${LLVM_MAIN_INCLUDE_DIR}/llvm/Config/llvm-config.h.cmake
+ ${LLVM_BINARY_DIR}/include/llvm/Config/llvm-config.h)
+
+configure_file(
+ ${LLVM_MAIN_INCLUDE_DIR}/llvm/Support/DataTypes.h.cmake
+ ${LLVM_BINARY_DIR}/include/llvm/Support/DataTypes.h)
set( CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LLVM_TOOLS_BINARY_DIR} )
set( CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
-# set(CMAKE_VERBOSE_MAKEFILE true)
-
-add_llvm_definitions( -D__STDC_LIMIT_MACROS )
-add_llvm_definitions( -D__STDC_CONSTANT_MACROS )
-
# MSVC has a gazillion warnings with this.
if( MSVC )
option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." OFF)
@@ -252,71 +196,6 @@ endif()
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)
option(LLVM_ENABLE_WERROR "Fail and stop if a warning is triggered." OFF)
-if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
- # TODO: support other platforms and toolchains.
- option(LLVM_BUILD_32_BITS "Build 32 bits executables and libraries." OFF)
- if( LLVM_BUILD_32_BITS )
- message(STATUS "Building 32 bits executables and libraries.")
- add_llvm_definitions( -m32 )
- list(APPEND CMAKE_EXE_LINKER_FLAGS -m32)
- list(APPEND CMAKE_SHARED_LINKER_FLAGS -m32)
- endif( LLVM_BUILD_32_BITS )
-endif( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
-
-if( MSVC )
- include(ChooseMSVCCRT)
-
- # Add definitions that make MSVC much less annoying.
- add_llvm_definitions(
- # For some reason MS wants to deprecate a bunch of standard functions...
- -D_CRT_SECURE_NO_DEPRECATE
- -D_CRT_SECURE_NO_WARNINGS
- -D_CRT_NONSTDC_NO_DEPRECATE
- -D_CRT_NONSTDC_NO_WARNINGS
- -D_SCL_SECURE_NO_DEPRECATE
- -D_SCL_SECURE_NO_WARNINGS
-
- -wd4146 # Suppress 'unary minus operator applied to unsigned type, result still unsigned'
- -wd4180 # Suppress 'qualifier applied to function type has no meaning; ignored'
- -wd4224 # Suppress 'nonstandard extension used : formal parameter 'identifier' was previously defined as a type'
- -wd4244 # Suppress ''argument' : conversion from 'type1' to 'type2', possible loss of data'
- -wd4267 # Suppress ''var' : conversion from 'size_t' to 'type', possible loss of data'
- -wd4275 # Suppress 'An exported class was derived from a class that was not exported.'
- -wd4291 # Suppress ''declaration' : no matching operator delete found; memory will not be freed if initialization throws an exception'
- -wd4345 # Suppress 'behavior change: an object of POD type constructed with an initializer of the form () will be default-initialized'
- -wd4351 # Suppress 'new behavior: elements of array 'array' will be default initialized'
- -wd4355 # Suppress ''this' : used in base member initializer list'
- -wd4503 # Suppress ''identifier' : decorated name length exceeded, name was truncated'
- -wd4624 # Suppress ''derived class' : destructor could not be generated because a base class destructor is inaccessible'
- -wd4715 # Suppress ''function' : not all control paths return a value'
- -wd4800 # Suppress ''type' : forcing value to bool 'true' or 'false' (performance warning)'
- -wd4065 # Suppress 'switch statement contains 'default' but no 'case' labels'
-
- -w14062 # Promote "enumerator in switch of enum is not handled" to level 1 warning.
- )
-
- # Enable warnings
- if (LLVM_ENABLE_WARNINGS)
- add_llvm_definitions( /W4 /Wall )
- if (LLVM_ENABLE_PEDANTIC)
- # No MSVC equivalent available
- endif (LLVM_ENABLE_PEDANTIC)
- endif (LLVM_ENABLE_WARNINGS)
- if (LLVM_ENABLE_WERROR)
- add_llvm_definitions( /WX )
- endif (LLVM_ENABLE_WERROR)
-elseif( CMAKE_COMPILER_IS_GNUCXX )
- if (LLVM_ENABLE_WARNINGS)
- add_llvm_definitions( -Wall -W -Wno-unused-parameter -Wwrite-strings )
- if (LLVM_ENABLE_PEDANTIC)
- add_llvm_definitions( -pedantic -Wno-long-long )
- endif (LLVM_ENABLE_PEDANTIC)
- endif (LLVM_ENABLE_WARNINGS)
- if (LLVM_ENABLE_WERROR)
- add_llvm_definitions( -Werror )
- endif (LLVM_ENABLE_WERROR)
-endif( MSVC )
-
include_directories( ${LLVM_BINARY_DIR}/include ${LLVM_MAIN_INCLUDE_DIR})
if( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )