summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-03 22:47:59 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-03 22:47:59 +0000
commitd931dca6e57cf9ceb4ceb04c23debe93e96eb7f9 (patch)
tree43f4b039a81a7f378621c742bd2784ecc19d1816 /CMakeLists.txt
parent0ecd2964214374045e699e3dc58c9093d9686293 (diff)
downloadllvm-d931dca6e57cf9ceb4ceb04c23debe93e96eb7f9.tar.gz
llvm-d931dca6e57cf9ceb4ceb04c23debe93e96eb7f9.tar.bz2
llvm-d931dca6e57cf9ceb4ceb04c23debe93e96eb7f9.tar.xz
Moved to Clang's source tree its configuration options and associated
macros. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@124824 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aaf6e9cb9a..e436c1c757 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,9 +101,6 @@ else( MSVC )
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )
-set(CLANG_RESOURCE_DIR "" CACHE STRING
- "Relative directory from the Clang binary to its resource files.")
-
option(LLVM_ENABLE_CBE_PRINTF_A "Set to ON if CBE is enabled for printf %a output" ON)
if(LLVM_ENABLE_CBE_PRINTF_A)
set(ENABLE_CBE_PRINTF_A 1)
@@ -118,9 +115,6 @@ option(LLVM_ENABLE_FFI "Use libffi to call external functions from the interpret
set(FFI_LIBRARY_DIR "" CACHE PATH "Additional directory, where CMake should search for libffi.so")
set(FFI_INCLUDE_DIR "" CACHE PATH "Additional directory, where CMake should search for ffi.h or ffi/ffi.h")
-set(C_INCLUDE_DIRS "" CACHE STRING
- "Colon separated list of directories clang will search for headers.")
-
set(LLVM_TARGET_ARCH "host"
CACHE STRING "Set target to use for LLVM JIT or use \"host\" for automatic detection.")