summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-08-15 23:44:31 +0000
committerHans Wennborg <hans@hanshq.net>2013-08-15 23:44:31 +0000
commitda44b4f68bcf2adcb74214670a266b43a1a6888f (patch)
treeea9197a4b26082aab6c8250a503484bbc3523e2b /CMakeLists.txt
parentd5f33aa33fbf865e15a3dced11b847e88f6a8239 (diff)
downloadllvm-da44b4f68bcf2adcb74214670a266b43a1a6888f.tar.gz
llvm-da44b4f68bcf2adcb74214670a266b43a1a6888f.tar.bz2
llvm-da44b4f68bcf2adcb74214670a266b43a1a6888f.tar.xz
CMake: polish the Windows packaging rules
This tweaks the CMake rules for building an installation package on Windows: - Sets license file (otherwise nsis shows an ugly default) - Adds LLVM logo - Shows "do you want to add this to the system path" dialog. Differential Revision: http://llvm-reviews.chandlerc.com/D1414 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@188509 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c71f74e67c..27010d2c53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -493,7 +493,16 @@ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/include/
set(CPACK_PACKAGE_VENDOR "LLVM")
set(CPACK_PACKAGE_VERSION_MAJOR ${LLVM_VERSION_MAJOR})
set(CPACK_PACKAGE_VERSION_MINOR ${LLVM_VERSION_MINOR})
-add_version_info_from_vcs(CPACK_PACKAGE_VERSION_PATCH)
+if( LLVM_APPEND_VC_REV )
+ add_version_info_from_vcs(CPACK_PACKAGE_VERSION_PATCH)
+else()
+ set(CPACK_PACKAGE_VERSION_PATCH "svn")
+endif()
+set(CPACK_RESOURCE_FILE_LICENSE "${LLVM_MAIN_SRC_DIR}/LICENSE.TXT")
+if(WIN32 AND NOT UNIX)
+ set(CPACK_PACKAGE_ICON "${LLVM_MAIN_SRC_DIR}\\\\cmake\\\\nsis_logo.bmp")
+ set(CPACK_NSIS_MODIFY_PATH "ON")
+endif()
include(CPack)
# Workaround for MSVS10 to avoid the Dialog Hell