summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-03-23 17:42:13 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-03-23 17:42:13 +0000
commitdb3480c432bff2be4ab26630343545ba66f00dac (patch)
treef4b5ba7eaefa78a99c023f35a60ee6b607d74463 /CMakeLists.txt
parentd662576671cba43988ff2753e1d006e50c568241 (diff)
downloadllvm-db3480c432bff2be4ab26630343545ba66f00dac.tar.gz
llvm-db3480c432bff2be4ab26630343545ba66f00dac.tar.bz2
llvm-db3480c432bff2be4ab26630343545ba66f00dac.tar.xz
Supports building with a list of targets that does not contain
X86. Fixes PR9533. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@128154 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9474ca819b..471b45eb81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,6 +81,9 @@ set(LLVM_ALL_TARGETS
XCore
)
+# List of targets with JIT support:
+set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM)
+
if( MSVC )
set(LLVM_TARGETS_TO_BUILD X86
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")