summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2011-10-06 01:51:51 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2011-10-06 01:51:51 +0000
commitde8f33c199f3bf2049b0b732169f2bd8717469c6 (patch)
tree4906ed892dbff03bbd44aae2eff9d7ec0c195755 /CMakeLists.txt
parent930193cb5544bd010a0a2bc795c9006913e2c595 (diff)
downloadllvm-de8f33c199f3bf2049b0b732169f2bd8717469c6.tar.gz
llvm-de8f33c199f3bf2049b0b732169f2bd8717469c6.tar.bz2
llvm-de8f33c199f3bf2049b0b732169f2bd8717469c6.tar.xz
Build system infrastructure for multiple tblgens.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@141266 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 874f381a21..039f619ff9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,6 +187,10 @@ endif( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
include(AddLLVM)
include(TableGen)
+macro(llvm_tablegen)
+ tablegen(LLVM ${ARGN})
+endmacro()
+
if( MINGW )
# People report that -O3 is unreliable on MinGW. The traditional
# build also uses -O2 for that reason:
@@ -197,18 +201,8 @@ endif()
add_subdirectory(lib/Support)
add_subdirectory(lib/TableGen)
-set(LLVM_TABLEGEN "tblgen" CACHE
- STRING "Native TableGen executable. Saves building one when cross-compiling.")
-# Effective tblgen executable to be used:
-set(LLVM_TABLEGEN_EXE ${LLVM_TABLEGEN})
-
add_subdirectory(utils/TableGen)
-if( CMAKE_CROSSCOMPILING )
- # This adds a dependency on target `tblgen', so must go after utils/TableGen
- include( CrossCompileLLVM )
-endif( CMAKE_CROSSCOMPILING )
-
add_subdirectory(include/llvm)
add_subdirectory(lib)