summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-10-25 03:29:36 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-10-25 03:29:36 +0000
commitde98db33fb10a13ead2fa56d6d4c944cedb8fbad (patch)
treef30b434377fcaeadaf87ab54a4c4e856995310da /CMakeLists.txt
parentcd6213233ea584531cf4c137db838551a3c454ff (diff)
downloadllvm-de98db33fb10a13ead2fa56d6d4c944cedb8fbad.tar.gz
llvm-de98db33fb10a13ead2fa56d6d4c944cedb8fbad.tar.bz2
llvm-de98db33fb10a13ead2fa56d6d4c944cedb8fbad.tar.xz
CMake: MSVC++ no longer uses a special configuration method.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@58132 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 837e8c1aaf..76ed06cad6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,13 +65,7 @@ endif( EXISTS ${LLVM_TOOLS_BINARY_DIR}/llvm-config )
# find_file(HAVE_LLVM_CONFIG llvm-config ${LLVM_TOOLS_BINARY_DIR})
# message(STATUS ${HAVE_LLVM_CONFIG})
-if( MSVC )
- message(STATUS "Configuring using MSVC hack.")
- include(config-w32)
-else( MSVC )
- message(STATUS "Configuring traditional style.")
- include(config-ix)
-endif( MSVC )
+include(config-ix)
set( CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LLVM_TOOLS_BINARY_DIR} )
set( CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )