summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <reid@kleckner.net>2013-06-24 13:21:16 +0000
committerReid Kleckner <reid@kleckner.net>2013-06-24 13:21:16 +0000
commitdfad9e314e3425ac2656ee08cd20c5b306514e51 (patch)
tree6383408f3846816b44c83ce521155d703a7df800 /CMakeLists.txt
parente7a939e1d8e4a4ec4155e2aaf7052d2a63efa140 (diff)
downloadllvm-dfad9e314e3425ac2656ee08cd20c5b306514e51.tar.gz
llvm-dfad9e314e3425ac2656ee08cd20c5b306514e51.tar.bz2
llvm-dfad9e314e3425ac2656ee08cd20c5b306514e51.tar.xz
Look for Python 2 before Python 3 in CMakeLists.txt
All of LLVM's Python scripts only support Python 2 for widely understood reasons. Patch by Yonggang Luo. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@184732 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb70f15880..b313780a41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -250,7 +250,8 @@ set(TARGET_TRIPLE "${LLVM_DEFAULT_TARGET_TRIPLE}")
include(HandleLLVMOptions)
-# Verify that we can find a Python interpreter,
+# Verify that we can find a Python 2 interpreter. Python 3 is unsupported.
+set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5 2.4)
include(FindPythonInterp)
if( NOT PYTHONINTERP_FOUND )
message(FATAL_ERROR