summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Pop <spop@codeaurora.org>2014-03-11 22:42:07 +0000
committerSebastian Pop <spop@codeaurora.org>2014-03-11 22:42:07 +0000
commite5b11b349bf91812a5dc65b320e067b2ec30d215 (patch)
tree4fdc802e3941d4b62859e8db5a73f437e32581d6 /CMakeLists.txt
parent667376028fc44bbcd861e6a70ff0e04b29f177d1 (diff)
downloadllvm-e5b11b349bf91812a5dc65b320e067b2ec30d215.tar.gz
llvm-e5b11b349bf91812a5dc65b320e067b2ec30d215.tar.bz2
llvm-e5b11b349bf91812a5dc65b320e067b2ec30d215.tar.xz
move WITH_POLLY option before add_subdirectory(tools)
the first run of the polly buildbot failed, and then it started passing. This is due to the fact that the buildbot re-builds in an existing directory, and the first run does not have WITH_POLLY set when it enters tools/. Thus, cmake ignores the tools/polly dir in the first run, and then because it reuses the CMakeCache.txt of the previous run, it has the WITH_POLLY set by the previous run, and so it passes the second time. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@203615 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e758f3fb7..49d1296950 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -502,6 +502,13 @@ endif()
add_subdirectory(projects)
+option(WITH_POLLY "Build LLVM with Polly" ON)
+if(WITH_POLLY)
+ if(NOT EXISTS ${LLVM_MAIN_SRC_DIR}/tools/polly/CMakeLists.txt)
+ set(WITH_POLLY OFF)
+ endif()
+endif(WITH_POLLY)
+
if( LLVM_INCLUDE_TOOLS )
add_subdirectory(tools)
endif()
@@ -564,10 +571,3 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
PATTERN ".svn" EXCLUDE
)
endif()
-
-option(WITH_POLLY "Build LLVM with Polly" ON)
-if(WITH_POLLY)
- if(NOT EXISTS ${LLVM_MAIN_SRC_DIR}/tools/polly/CMakeLists.txt)
- set(WITH_POLLY OFF)
- endif()
-endif(WITH_POLLY)