summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Lewycky <nicholas@mxc.ca>2011-04-26 05:48:41 +0000
committerNick Lewycky <nicholas@mxc.ca>2011-04-26 05:48:41 +0000
commite88c724ff09b3d24bcb515b382ded9ee4e885ee5 (patch)
tree4ece0d39540f58da1768fc00bad93e907c79c497 /CMakeLists.txt
parentb16d06f88a81a5163e0caffad4bb268a8e1d0204 (diff)
downloadllvm-e88c724ff09b3d24bcb515b382ded9ee4e885ee5.tar.gz
llvm-e88c724ff09b3d24bcb515b382ded9ee4e885ee5.tar.bz2
llvm-e88c724ff09b3d24bcb515b382ded9ee4e885ee5.tar.xz
Add cmakefiles to build profile_rt.so!
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@130191 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48cd55b095..38a9f2b227 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -227,6 +227,13 @@ if( LLVM_INCLUDE_TOOLS )
add_subdirectory(tools)
endif()
+option(LLVM_BUILD_RUNTIME
+ "Build the LLVM runtime libraries. If OFF, just generate build targets." OFF)
+option(LLVM_INCLUDE_RUNTIME "Generate build targets for the LLVM runtimes" ON)
+if( LLVM_INCLUDE_RUNTIME )
+ add_subdirectory(runtime)
+endif()
+
option(LLVM_BUILD_EXAMPLES
"Build the LLVM example programs. If OFF, just generate build targets." OFF)
option(LLVM_INCLUDE_EXAMPLES "Generate build targets for the LLVM examples" ON)
@@ -235,7 +242,7 @@ if( LLVM_INCLUDE_EXAMPLES )
endif()
option(LLVM_BUILD_TESTS
- "Build LLVM unit tests. If OFF, just generate build targes." OFF)
+ "Build LLVM unit tests. If OFF, just generate build targets." OFF)
if( LLVM_INCLUDE_TESTS )
add_subdirectory(test)
add_subdirectory(utils/unittest)