summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-07-05 23:58:20 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-07-05 23:58:20 +0000
commite8c81ea3f8e00c55f55d7f0aa9a1ff6a97211786 (patch)
treed42e75e51ba30488782b1dc0032312f6b479cc33 /CMakeLists.txt
parent0a205a459884ec745df1c529396dd921f029dafd (diff)
downloadllvm-e8c81ea3f8e00c55f55d7f0aa9a1ff6a97211786.tar.gz
llvm-e8c81ea3f8e00c55f55d7f0aa9a1ff6a97211786.tar.bz2
llvm-e8c81ea3f8e00c55f55d7f0aa9a1ff6a97211786.tar.xz
CMake: Fixes previous change: CMAKE_BUILD_TYPE is unknown when
generating project files for MSVC. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@74809 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6abfa4f215..2a59efb771 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ endif()
if( LLVM_ENABLE_ASSERTIONS )
# MSVC doesn't like _DEBUG on release builds. See PR 4379.
- if( NOT MSVC OR NOT uppercase_CMAKE_BUILD_TYPE STREQUAL "RELEASE" )
+ if( NOT MSVC )
add_definitions( -D_DEBUG )
endif()
# On Release builds cmake automatically defines NDEBUG, so we