summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2009-07-16 00:35:05 +0000
committerDaniel Dunbar <daniel@zuster.org>2009-07-16 00:35:05 +0000
commitfef02e9af2250b5bc6cfe4ed1f018d4a5383809c (patch)
tree04a0e6d8b3bfcad8b42cac42c48ee5f66079b1d8 /CMakeLists.txt
parent4f80d718eb92506739fc78804b7b0fd3a5e15aa3 (diff)
downloadllvm-fef02e9af2250b5bc6cfe4ed1f018d4a5383809c.tar.gz
llvm-fef02e9af2250b5bc6cfe4ed1f018d4a5383809c.tar.bz2
llvm-fef02e9af2250b5bc6cfe4ed1f018d4a5383809c.tar.xz
Kill off cmake magic to force linking.
- This isn't needed anymore, we require clients to call the appropriate initialization routines using TargetSelect.h. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@75871 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77650656e5..d97ac8d8f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,10 +63,6 @@ set(LLVM_ALL_TARGETS
XCore
)
-# List of targets whose asmprinters need to be forced to link
-# into executables on some platforms (i.e. Windows):
-set(LLVM_ASMPRINTERS_FORCE_LINK X86 PowerPC)
-
if( MSVC )
set(LLVM_TARGETS_TO_BUILD X86
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")