summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2005-02-24 18:31:27 +0000
committerReid Spencer <rspencer@reidspencer.com>2005-02-24 18:31:27 +0000
commit1807c1a3c9013ab5075faa40add4d69ec5a8a29d (patch)
treeb8e34a0e1a31043664483af3e11c7a2125667103 /autoconf/configure.ac
parenta8d9789a7a068aa12745f00710bfb707831f8711 (diff)
downloadllvm-1807c1a3c9013ab5075faa40add4d69ec5a8a29d.tar.gz
llvm-1807c1a3c9013ab5075faa40add4d69ec5a8a29d.tar.bz2
llvm-1807c1a3c9013ab5075faa40add4d69ec5a8a29d.tar.xz
Add a call to AC_CONFIG_COMMANDS to ensure that llvm_src is set properly
in the config.status script. This allows the AC_CONFIG_MAKEFILE macro to work properly after it was changed to support sub-projects. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@20305 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 64dfc11ea1..fa827cb026 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -586,6 +586,7 @@ dnl Configure doxygen's configuration file
AC_CONFIG_FILES([docs/doxygen.cfg])
dnl Do special configuration of Makefiles
+AC_CONFIG_COMMANDS([setup],,[llvm_src="${srcdir}"])
AC_CONFIG_MAKEFILE(Makefile)
AC_CONFIG_MAKEFILE(Makefile.common)
AC_CONFIG_MAKEFILE(examples/Makefile)