summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorBob Wilson <bob.wilson@apple.com>2013-08-02 22:51:06 +0000
committerBob Wilson <bob.wilson@apple.com>2013-08-02 22:51:06 +0000
commit244acf3a4b172657924d21bbb3a65f6388cb68bd (patch)
tree763ca3cb635a2db45d48d080f339e7a31e8576b6 /autoconf/configure.ac
parent40bacacad3dac9eb5202193f685719d0f37d7f4a (diff)
downloadllvm-244acf3a4b172657924d21bbb3a65f6388cb68bd.tar.gz
llvm-244acf3a4b172657924d21bbb3a65f6388cb68bd.tar.bz2
llvm-244acf3a4b172657924d21bbb3a65f6388cb68bd.tar.xz
Link with -rdynamic instead of -Wl,-export-dynamic.
Recent versions of the OS X linker support this but follow the existing OS X linker convention of using an underscore in the option name, i.e., -export_dynamic. Rather than changing our configure scripts to check for that alternate spelling, it is simpler to just use the compiler's -rdynamic option and let it deal with translating that to the appropriate linker option. One potential disadvantage of this approach is that the compiler will typically ignore -rdynamic on platforms where it is not supported, so the HAVE_LINK_EXPORT_DYNAMIC in config.h will not necessarily show whether that option has any effect or not. I don't see any in-tree uses of that macro, so I'm assuming it is OK. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@187686 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 97a14293ea..5be25af2ad 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -1239,7 +1239,7 @@ AC_LINK_GET_VERSION
dnl Determine whether the linker supports the -R option.
AC_LINK_USE_R
-dnl Determine whether the linker supports the -export-dynamic option.
+dnl Determine whether the compiler supports the -rdynamic option.
AC_LINK_EXPORT_DYNAMIC
dnl Determine whether the linker supports the --version-script option.
@@ -1863,7 +1863,7 @@ AC_SUBST(RPATH)
dnl Determine linker rdynamic flag
if test "$llvm_cv_link_use_export_dynamic" = "yes" ; then
- RDYNAMIC="-Wl,-export-dynamic"
+ RDYNAMIC="-rdynamic"
else
RDYNAMIC=""
fi