summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorGabor Greif <ggreif@gmail.com>2009-08-25 23:02:21 +0000
committerGabor Greif <ggreif@gmail.com>2009-08-25 23:02:21 +0000
commit2f3fa88a2515e1ba9c5a3a8cc4add0b79b492ba0 (patch)
tree9dbc79d0db66426c645d894996472e8eb45883b4 /autoconf/configure.ac
parent77f452d1a83054f0451ef8421297ffc8294f45dd (diff)
downloadllvm-2f3fa88a2515e1ba9c5a3a8cc4add0b79b492ba0.tar.gz
llvm-2f3fa88a2515e1ba9c5a3a8cc4add0b79b492ba0.tar.bz2
llvm-2f3fa88a2515e1ba9c5a3a8cc4add0b79b492ba0.tar.xz
revert r78628 and r78803 as these are not needed any more
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@80048 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 22e4076a02..173341a054 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -361,17 +361,6 @@ else
AC_SUBST(DISABLE_ASSERTIONS,[[DISABLE_ASSERTIONS=1]])
fi
-dnl LLVM_COMPACT_SENTINELS : can be used to shrink ilist's end iterators and disable certain checks on them:
-if test ${ENABLE_OPTIMIZED},${DISABLE_ASSERTIONS} = "ENABLE_OPTIMIZED=1,DISABLE_ASSERTIONS=1" ; then
- AC_SUBST(LLVM_COMPACT_SENTINELS,[1])
-else
- AC_SUBST(LLVM_COMPACT_SENTINELS,[0])
-fi
-
-AC_DEFINE_UNQUOTED([LLVM_COMPACT_SENTINELS],$LLVM_COMPACT_SENTINELS,
- [Define to 1 for ilist sentinel compaction])
-
-
dnl --enable-expensive-checks : check whether they want to turn on expensive debug checks:
AC_ARG_ENABLE(expensive-checks,AS_HELP_STRING(
--enable-expensive-checks,[Compile with expensive debug checks enabled (default is NO)]),, enableval="no")