summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorDylan Noblesmith <nobled@dreamwidth.org>2012-02-02 00:54:18 +0000
committerDylan Noblesmith <nobled@dreamwidth.org>2012-02-02 00:54:18 +0000
commit32cf80bd01775fe9cc45a2416824af353da193c6 (patch)
treee1575483b193827781502cd1b2e34ae7e0616c66 /autoconf/configure.ac
parentac89865faf7abf8fcae4996f12e9358e84e0c337 (diff)
downloadllvm-32cf80bd01775fe9cc45a2416824af353da193c6.tar.gz
llvm-32cf80bd01775fe9cc45a2416824af353da193c6.tar.bz2
llvm-32cf80bd01775fe9cc45a2416824af353da193c6.tar.xz
autoconf: fix build/src dir confusion
This was the cause of the silent failure to generate clang's config.h. My bad. Fix on r149563 / r149568. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@149574 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index c9757d9ff7..6316be9c52 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -1589,7 +1589,7 @@ AC_CONFIG_FILES([docs/doxygen.cfg])
dnl Configure clang, if present
if test ${clang_src_root} = ""; then
- clang_src_root="$ac_pwd/tools/clang"
+ clang_src_root="$srcdir/tools/clang"
fi
if test -f ${clang_src_root}/README.txt; then
AC_CONFIG_HEADERS([${clang_src_root}/include/clang/Config/config.h])