summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2006-06-01 16:55:59 +0000
committerReid Spencer <rspencer@reidspencer.com>2006-06-01 16:55:59 +0000
commit484fc8e38421f5b26593a9edacd734baf844c9e9 (patch)
tree6821780a044b414961c112182c2849bac54e23b9 /autoconf/configure.ac
parentb056761165e2fb7409d21abaec3937eae874e995 (diff)
downloadllvm-484fc8e38421f5b26593a9edacd734baf844c9e9.tar.gz
llvm-484fc8e38421f5b26593a9edacd734baf844c9e9.tar.bz2
llvm-484fc8e38421f5b26593a9edacd734baf844c9e9.tar.xz
Provide support for detecting if the Win32 imaghlp and psapi libraries
are available. These libraries are used in lib/System and should be included on the link line or if not available generate an error when building lib/System. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@28628 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 954dd38b8f..677164faa2 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -486,6 +486,11 @@ dnl===-----------------------------------------------------------------------===
dnl libelf is for sparc only; we can ignore it if we don't have it
AC_CHECK_LIB(elf, elf_begin)
AC_CHECK_LIB(m,sin)
+if test "$llvm_cv_os_type" == "MingW" ; then
+ AC_CHECK_HEADERS([imagehlp.h psapi.h])
+ AC_CHECK_LIB(imagehlp,[SymGetOptions])
+ AC_CHECK_LIB(psapi,[GetProcessMemoryInfo])
+fi
dnl lt_dlopen may be required for plugin support.
AC_SEARCH_LIBS(lt_dlopen,ltdl,AC_DEFINE([HAVE_LT_DLOPEN],[1],