summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorNick Lewycky <nicholas@mxc.ca>2009-09-29 05:40:45 +0000
committerNick Lewycky <nicholas@mxc.ca>2009-09-29 05:40:45 +0000
commit558aef86c2d923e2c4bb62a7cf328dd5869525de (patch)
tree6c3105edc31fa3f0b8c9220b2ffbb21c1f9d4a98 /autoconf/configure.ac
parent0475c9170e9621292a48c688c3976031be5650bb (diff)
downloadllvm-558aef86c2d923e2c4bb62a7cf328dd5869525de.tar.gz
llvm-558aef86c2d923e2c4bb62a7cf328dd5869525de.tar.bz2
llvm-558aef86c2d923e2c4bb62a7cf328dd5869525de.tar.xz
On Linux, uname -m reports the kernel type. Some Linux systems are 32-bit but
with a 64-bit kernel, which confuses LLVM. Make LLVM double-check this by checking which defines the system gcc actually sets. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@83047 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index e305869342..bdd665ccd6 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -284,6 +284,14 @@ if test "$llvm_cv_target_arch" = "Unknown" ; then
AC_MSG_WARN([Configuring LLVM for an unknown target archicture])
fi
+dnl Handle 32-bit linux systems running a 64-bit kernel.
+if test "$llvm_cv_os_type" = "Linux" -a "$llvm_cv_target_arch" = "x86_64" ; then
+ AC_IS_LINUX_MIXED
+ if test "$llvm_cv_linux_mixed" = "yes"; then
+ llvm_cv_target_arch="x86"
+ fi
+fi
+
# Determine the LLVM native architecture for the target
case "$llvm_cv_target_arch" in
x86) LLVM_NATIVE_ARCH="X86" ;;