summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorJohn Criswell <criswell@uiuc.edu>2004-07-19 16:12:29 +0000
committerJohn Criswell <criswell@uiuc.edu>2004-07-19 16:12:29 +0000
commit7ed43ad3ab29be753b514966476c76206d0c0648 (patch)
treee7c52c4ddc94112fafaf463ca139c22640877d59 /autoconf/configure.ac
parent8640f4e666086cc6e7447dc164105e428e6cb81a (diff)
downloadllvm-7ed43ad3ab29be753b514966476c76206d0c0648.tar.gz
llvm-7ed43ad3ab29be753b514966476c76206d0c0648.tar.bz2
llvm-7ed43ad3ab29be753b514966476c76206d0c0648.tar.xz
Added support for stdint.h. It is now automatically included by
DataTypes.h. So far, it doesn't seem to break Linux, Solaris, or MacOS X. This should automatically include it for those people who need it. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@15006 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index aebb7d6ba8..abece9f0d9 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -250,6 +250,11 @@ AC_CHECK_HEADER([inttypes.h],
[INCLUDE_INTTYPES_H='#include <inttypes.h>'],
[INCLUDE_INTTYPES_H=''])
AC_SUBST(INCLUDE_INTTYPES_H)
+AC_CHECK_HEADER([stdint.h],
+ [INCLUDE_STDINT_H='#include <stdint.h>'],
+ [INCLUDE_STDINT_H=''])
+AC_SUBST(INCLUDE_STDINT_H)
+
dnl Check for types
AC_TYPE_PID_T