summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2009-11-12 05:46:09 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2009-11-12 05:46:09 +0000
commit7f9ec910a38f769dc91f1b3b3a9b50ee1cecff19 (patch)
tree95a5bd16a3cb0bc6eb3de2eceea85e9ddf45a146 /autoconf/configure.ac
parenta447cfea453b582092a7a1e5a7f71e695981c4d2 (diff)
downloadllvm-7f9ec910a38f769dc91f1b3b3a9b50ee1cecff19.tar.gz
llvm-7f9ec910a38f769dc91f1b3b3a9b50ee1cecff19.tar.bz2
llvm-7f9ec910a38f769dc91f1b3b3a9b50ee1cecff19.tar.xz
Add the --with-c-include-dirs to llvm's configure.
The clang patch is next. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@86955 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 7d0a9bbf82..27340c7848 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -667,6 +667,13 @@ case "$withval" in
*) AC_MSG_ERROR([Invalid path for --with-ocaml-libdir. Provide full path]) ;;
esac
+AC_ARG_WITH(c-include-dir,
+ AS_HELP_STRING([--with-c-include-dirs],
+ [Colon separated list of directories clang will search for headers]),,
+ withval="")
+AC_DEFINE_UNQUOTED(C_INCLUDE_DIRS,"$withval",
+ [Directories clang will search for headers])
+
dnl Allow linking of LLVM with GPLv3 binutils code.
AC_ARG_WITH(binutils-include,
AS_HELP_STRING([--with-binutils-include],