summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorJeffrey Yasskin <jyasskin@google.com>2009-09-27 17:47:29 +0000
committerJeffrey Yasskin <jyasskin@google.com>2009-09-27 17:47:29 +0000
commit7fd82e56a8d6fd48dd22f85ce502c24ff599d7a8 (patch)
tree16920ae44894157411ddd102594bee0d84e3fa9f /autoconf/configure.ac
parent83d577490b1473213b6973236110c28e59127956 (diff)
downloadllvm-7fd82e56a8d6fd48dd22f85ce502c24ff599d7a8.tar.gz
llvm-7fd82e56a8d6fd48dd22f85ce502c24ff599d7a8.tar.bz2
llvm-7fd82e56a8d6fd48dd22f85ce502c24ff599d7a8.tar.xz
Enable -g with DEBUG_SYMBOLS and --enable-debug-symbols instead of
DEBUG_RUNTIME. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@82906 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 7d75eb28d3..e305869342 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -381,6 +381,16 @@ else
AC_SUBST(DEBUG_RUNTIME,[[DEBUG_RUNTIME=1]])
fi
+dnl --enable-debug-symbols : should even optimized compiler libraries
+dnl have debug symbols?
+AC_ARG_ENABLE(debug-symbols,
+ AS_HELP_STRING(--enable-debug-symbols,[Build compiler with debug symbols (default is NO if optimization is on and YES if it's off)]),,enableval=no)
+if test ${enableval} = "no" ; then
+ AC_SUBST(DEBUG_SYMBOLS,[[]])
+else
+ AC_SUBST(DEBUG_SYMBOLS,[[DEBUG_SYMBOLS=1]])
+fi
+
dnl --enable-jit: check whether they want to enable the jit
AC_ARG_ENABLE(jit,
AS_HELP_STRING(--enable-jit,