summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorBrian Gaeke <gaeke@uiuc.edu>2004-06-22 23:43:04 +0000
committerBrian Gaeke <gaeke@uiuc.edu>2004-06-22 23:43:04 +0000
commit8828eb58dd1b4171cbfee11a6b5146520da5208f (patch)
treebf607e390f4dbea4882a40430fc5a579561fcbee /autoconf/configure.ac
parent99913cad315d5eda5e8bb53aa325e5e4220734dd (diff)
downloadllvm-8828eb58dd1b4171cbfee11a6b5146520da5208f.tar.gz
llvm-8828eb58dd1b4171cbfee11a6b5146520da5208f.tar.bz2
llvm-8828eb58dd1b4171cbfee11a6b5146520da5208f.tar.xz
Call custom check (AC_FUNC_ISNAN) instead of using the generic function check.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@14335 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index ed08e8d94a..aebb7d6ba8 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -272,6 +272,8 @@ AC_CXX_HAVE_STD_ITERATOR
AC_CXX_HAVE_BI_ITERATOR
AC_CXX_HAVE_FWD_ITERATOR
+AC_FUNC_ISNAN
+
dnl Checks for library functions.
AC_FUNC_ALLOCA
AC_FUNC_MMAP
@@ -286,7 +288,7 @@ then
fi
AC_HEADER_MMAP_ANONYMOUS
AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(getcwd gettimeofday strdup strtoq strtoll backtrace isatty mkstemp getrusage isnan)
+AC_CHECK_FUNCS(getcwd gettimeofday strdup strtoq strtoll backtrace isatty mkstemp getrusage)
AC_CHECK_FUNC(mprotect,,AC_MSG_ERROR([Function mprotect() required but not found]))
dnl Determine if the linker supports the -R option.