summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2005-07-13 03:20:14 +0000
committerReid Spencer <rspencer@reidspencer.com>2005-07-13 03:20:14 +0000
commit8a2246f32ec6480b6430078ff2c5740a0a11a3fb (patch)
tree4173563087823f2fb66c3f6ba7360853dbab0302 /autoconf/configure.ac
parent2499841461a95872a9fe15d310f1d71f94af76d9 (diff)
downloadllvm-8a2246f32ec6480b6430078ff2c5740a0a11a3fb.tar.gz
llvm-8a2246f32ec6480b6430078ff2c5740a0a11a3fb.tar.bz2
llvm-8a2246f32ec6480b6430078ff2c5740a0a11a3fb.tar.xz
Implement a test for the Graphviz program for Chris Lattner. The symbol
GRAPHVIZ will contain the path to the program if its found (or "echo Graphviz" if not) and the #define HAVE_GRAPHVIZ will be defined if its found. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@22424 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index f20c567f03..b12c32136f 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -304,6 +304,10 @@ AC_PROG_RANLIB
AC_PATH_PROG(RM, [rm], [rm])
AC_PATH_PROG(SED, [sed], [sed])
AC_PATH_PROG(TAR, [tar], [gtar])
+AC_PATH_PROG(GRAPHVIZ, [Graphviz], [echo GraphViz])
+if test "$GRAPHVIZ" != "echo GraphViz" ; then
+ AC_DEFINE([HAVE_GRAPHVIZ],[1],[Define if the Graphviz program is available])
+fi
dnl Find the install program
AC_PROG_INSTALL