summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorJohn Criswell <criswell@uiuc.edu>2004-06-22 21:35:10 +0000
committerJohn Criswell <criswell@uiuc.edu>2004-06-22 21:35:10 +0000
commit8a54a1ed40d3067b32d9bf3a34f04dc55651ad00 (patch)
treed5cde7b6b4f2cb1bd4d19a0196ea58636362cda1 /autoconf/configure.ac
parentf54d912e32d19037391a59fc37336486b280187d (diff)
downloadllvm-8a54a1ed40d3067b32d9bf3a34f04dc55651ad00.tar.gz
llvm-8a54a1ed40d3067b32d9bf3a34f04dc55651ad00.tar.bz2
llvm-8a54a1ed40d3067b32d9bf3a34f04dc55651ad00.tar.xz
Added the llvm/test/Programs/Makefile.test Makefile.
Added a check for isnan() while I was at it. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@14333 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 0603c3cd05..ed08e8d94a 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -38,6 +38,7 @@ AC_CONFIG_MAKEFILE(test/QMTest/llvm.py)
AC_CONFIG_MAKEFILE(test/QMTest/llvmdb.py)
AC_CONFIG_MAKEFILE(test/Programs/Makefile)
AC_CONFIG_MAKEFILE(test/Programs/Makefile.programs)
+AC_CONFIG_MAKEFILE(test/Programs/Makefile.tests)
AC_CONFIG_MAKEFILE(test/Programs/TEST.aa.Makefile)
AC_CONFIG_MAKEFILE(test/Programs/TEST.dsgraph.report)
AC_CONFIG_MAKEFILE(test/Programs/TEST.aa.report)
@@ -285,7 +286,7 @@ then
fi
AC_HEADER_MMAP_ANONYMOUS
AC_TYPE_SIGNAL
-AC_CHECK_FUNCS(getcwd gettimeofday strdup strtoq strtoll backtrace isatty mkstemp getrusage)
+AC_CHECK_FUNCS(getcwd gettimeofday strdup strtoq strtoll backtrace isatty mkstemp getrusage isnan)
AC_CHECK_FUNC(mprotect,,AC_MSG_ERROR([Function mprotect() required but not found]))
dnl Determine if the linker supports the -R option.