summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2004-12-31 22:54:28 +0000
committerReid Spencer <rspencer@reidspencer.com>2004-12-31 22:54:28 +0000
commitbbf7a8af5a7781cf0f721770ab81333f22c0f464 (patch)
tree894c186b98cbd1880660359d0986305b0a5f51ee /autoconf/configure.ac
parente0a7dddf3931be2901b48f4b1b5ad0fa74fae54f (diff)
downloadllvm-bbf7a8af5a7781cf0f721770ab81333f22c0f464.tar.gz
llvm-bbf7a8af5a7781cf0f721770ab81333f22c0f464.tar.bz2
llvm-bbf7a8af5a7781cf0f721770ab81333f22c0f464.tar.xz
For PR351:
Make LLVM_ON_UNIX and LLVM_ON_WIN32 available in the makefiles git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@19205 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index a236005ac2..2ed25da870 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -147,9 +147,13 @@ dnl to use.
case $llvm_cv_platform_type in
Unix)
AC_DEFINE([LLVM_ON_UNIX],[1],[Define if this is Unixish platform])
+ AC_SUBST(LLVM_ON_UNIX,[1])
+ AC_SUBST(LLVM_ON_WIN32,[0])
;;
Win32)
AC_DEFINE([LLVM_ON_WIN32],[1],[Define if this is Win32ish platform])
+ AC_SUBST(LLVM_ON_UNIX,[0])
+ AC_SUBST(LLVM_ON_WIN32,[1])
;;
esac