summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2005-07-14 02:25:12 +0000
committerReid Spencer <rspencer@reidspencer.com>2005-07-14 02:25:12 +0000
commitc232a658274117b8db1f6dfd1aa2dbb3ab390381 (patch)
treea495916a6ee965b80be49e3c4c8a1e345d1de9e6 /autoconf/configure.ac
parentf1a2f15ed35c1cf987f6a1a703f855a3c61fdab6 (diff)
downloadllvm-c232a658274117b8db1f6dfd1aa2dbb3ab390381.tar.gz
llvm-c232a658274117b8db1f6dfd1aa2dbb3ab390381.tar.bz2
llvm-c232a658274117b8db1f6dfd1aa2dbb3ab390381.tar.xz
Put the path to the Graphviz program in the #defines so it can be used.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@22430 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index b12c32136f..be1f1ddf13 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -304,9 +304,11 @@ AC_PROG_RANLIB
AC_PATH_PROG(RM, [rm], [rm])
AC_PATH_PROG(SED, [sed], [sed])
AC_PATH_PROG(TAR, [tar], [gtar])
-AC_PATH_PROG(GRAPHVIZ, [Graphviz], [echo GraphViz])
-if test "$GRAPHVIZ" != "echo GraphViz" ; then
+AC_PATH_PROG(GRAPHVIZ, [Graphviz], [echo Graphviz])
+if test "$GRAPHVIZ" != "echo Graphviz" ; then
AC_DEFINE([HAVE_GRAPHVIZ],[1],[Define if the Graphviz program is available])
+ AC_DEFINE([LLVM_PATH_GRAPHVIZ],"$GRAPHVIZ",
+ [Define to path to Graphviz program if found or 'echo Graphviz' otherwise])
fi
dnl Find the install program