summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2006-04-09 20:42:14 +0000
committerReid Spencer <rspencer@reidspencer.com>2006-04-09 20:42:14 +0000
commitc28ccd86b574cdcde54fa68f2f28e18f4b49498e (patch)
tree271e6278a89c105ad4d7e48e57a4470b25310c36 /autoconf/configure.ac
parent3df241e4b2b93329fdeea16a4eb366347442f99f (diff)
downloadllvm-c28ccd86b574cdcde54fa68f2f28e18f4b49498e.tar.gz
llvm-c28ccd86b574cdcde54fa68f2f28e18f4b49498e.tar.bz2
llvm-c28ccd86b574cdcde54fa68f2f28e18f4b49498e.tar.xz
Change the assertions defaults:
1. Assertions now default to on for all builds 2. If you want them disabled you must (a) --disable-assertions to configure or DISABLE_ASSERTIONS=1 to make. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@27548 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index fee1c2c4be..9959c6ee7a 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -193,12 +193,10 @@ dnl --enable-assertions below
if test -d "CVS" -o -d "${srcdir}/CVS"; then
cvsbuild="yes"
optimize="no"
- asserts="yes"
AC_SUBST(CVSBUILD,[[CVSBUILD=1]])
else
cvsbuild="no"
optimize="yes"
- asserts="no"
fi
dnl===-----------------------------------------------------------------------===
@@ -218,11 +216,11 @@ fi
dnl --enable-assertions : check whether they want to turn on assertions or not:
AC_ARG_ENABLE(assertions,AS_HELP_STRING(
- [--enable-assertions,Compile with assertion checks enabled (default is NO)]),, enableval=$asserts)
-if test ${enableval} = "no" ; then
- AC_SUBST(ENABLE_ASSERTIONS,[[]])
+ [--enable-assertions,Compile with assertion checks enabled (default is YES)]),, enableval="yes")
+if test ${enableval} = "yes" ; then
+ AC_SUBST(DISABLE_ASSERTIONS,[[]])
else
- AC_SUBST(ENABLE_ASSERTIONS,[[ENABLE_ASSERTIONS=1]])
+ AC_SUBST(DISABLE_ASSERTIONS,[[DISABLE_ASSERTIONS=1]])
fi
dnl --enable-debug-runtime : should runtime libraries have debug symbols?